After firmware upload LED is constantly blinking


#1

I tried to flash firmware bcf-kit-sigfox-climate-monitor, flasjing ended OK, after I disconnected core module from USN cable and attached batteries red LED dios started constantly blinking and module cannot be paired with USB dongle.

If I tried different firmware it was OK, so there is no HW problem. I was flashing with all other modules (battery, sigfox etc. disconnected).

What exactly that flashing means? Is there some documentation on that, some description what different types of blinking means?


#2

Hello Michal,

only firmwares starting with bcf-radio are communicating and pairing with USB Dongle.

Firmwares starting with bcf-sigfox needs Sigfox module connected and are using global Sigfox network. If the Core Module cannot initialize Sigfox Module, then it starts to blink, please see this line of code https://github.com/bigclownlabs/bcf-kit-sigfox-climate-monitor/blob/master/app/application.c#L97.

You mentioned that some other firmware “was OK”. Can you please explain which modules or project are you trying to create and which code worked for you in case you are still having troubles?

Thanks,
Martin


#3

Thanks, now it makes sense:-)

I have working set with bcf-radio-climate-monitor, I want to try sigfox, so my understanding was I will simply add sigfox module and use that fw which I thought is similar to that bcf-radio-climate-monitor just with extra sigfox functionality. And as my plan was “first have working receiving data via dongle and than move to sigfox” I got stuck. Now is clearer for me, so I will go trying again directly with sigfox.