Climate module shows incorrect pressure and altitude


I’m testing USB Dongle with two remotes:

  1. Standard battery, core, encoder, LCD and barometer, humidity and Lux tags.
  2. Mini battery, core, climate

I uploaded generic node fw to both nodes (I only updated standard battery fw to be remote as well), paired both with dongle and i can see values in mqtt-spy. But for some strange reason, the pressure from Climate module is very low. According to altitude, I’m currently 8 km above sea level :open_mouth:


Is this hw issue, calibration issue or SDK issue?

I updated my repo to latest version of bc-generic-node and updated sdk submodule as well and fresh compiled.

[21:36:24 marian@worker bcf-generic-node (master)]$ gl -1 |cat
commit f65934c43ca0a8b81cf3962ce813b1700df86192
Author: Karel Blavka <>
Date:   Fri Oct 20 20:35:36 2017 +0200

    Update travis
[21:36:29 marian@worker bcf-generic-node (master)]$ git submodule
 a887beb3a212c05769973ef82d8bd48504d8a200 sdk (remotes/origin/HEAD)
[21:36:39 marian@worker bcf-generic-node (master)]$ 

I used commands:

$ make release OUT="bcf-generic-node-battery-standard-dev"
$ make release BATTERY_MINI=1 OUT="bcf-generic-node-battery-mini-dev"


Can you try unplug and plug climate module ?
If it does it again, its hw issue.


Under power? Because without power I did it several times - I uploaded new fw and I needed access to Boot button. Still the same, wrong values. Not a big issue as I have barometer tag and I can use values from there. There should be not a big difference between outside and inside value.

I just wanted to be sure.


It looks like a hw problem.