No mqtt messages with Raspberry and core module as gateway


#1

Hi,
I finally hooked up bigclown modules to play with it…

I’d like to use a core module as gateway. So I followed this tutorial first: https://www.bigclown.com/doc/tutorials/raspberry-pi-tutorial/

I have bigclown image for raspi running, I’m logged in, it looks ok and I was able to flash the module:

pi@hub:~ $ bcf flash --device dfu bigclownlabs/bcf-gateway-core-module:v1.11.0
Flash [####################] 100.0%

Too bad I can’t see any messages :frowning:

mosquitto_sub -t "#" -v shows nothing.

The core module is the older one, R1.3.

Any hints, please?

Thanks


#2

The Core Module R1.3 uses native USB instead of FTDI. In linux it appears as /dev/ttyACM0. So you have to run the bcg service also for this different device.

You can also run bcg devices command to see all the serial ports.

In step 13 is explained how to run the service, just change the /dev/
https://www.bigclown.com/doc/tutorials/custom-setup-on-raspberry-pi/

In step 12 it has created device alias, but you can use the exact /dev/ name:

pm2 start /usr/bin/python3 --name "bcg-cm" -- /usr/local/bin/bcg --device /dev/ttyACM0
don’t forget to save settings by typing
pm2 save

If the above fails, you can run bcg manually like this, then please copy all the output to further debug this issue:

bcg --device /dev/ttyACM0 --debug

Using Core Module as a gateway is not recommended. The way to go is really using the Radio Dongle.

Martin


#3

Thank you, that’s the trick. Now I understand how it works, great.

Right now I don’t have the radio dongle, so I’ll test it using the core module as gateway and the see what next.