Relay Module V1.1 not supported?


#1

Hi all,
I have Relay module V1.1 and I try it with FW generic-node but relay dont respond to MQTT commands. I change BC_RADIO_MODE_NODE_SLEEPING to BC_RADIO_MODE_NODE_LISTENING but still without respond. Some ideas ?


#2

Hi,
relays are supported, the version does not matter.

If you upload bcf-generic-node-power-module-rgbw144 firmware from the BigClown Playground, it must work.

If you compile firmware yourself, then default “make” command compiles battery versions and do not add functions to control relays. Please take a look at our build script to see how to compile different versions.

This is probably what you want.

make release MODULE_POWER=1

You also don’t have to edit SLEEPING and LISTENING, because it is taken care automatically here


#3

On the first try console
image

after make (withouth options) I can compile default code in ./out/debug
and after that i try make release MODULE_POWER=1 again and it compile to ./out/release with some problems


after flash it I try it and relay still dont work and also LED on core module dont work.
Iam sad :frowning:


#4

Hi,

can you confirm that bcf-generic-node-power-module-rgbw144 firmware from the BigClown Playground works? First let’s make sure that the hardware and default firmware is ok and then we move to custom firmware.

The warnings are ok, important is what the compiler dispalys at the end. Can you show the complete build log?

I see you are using Windows, the make release MODULE_POWER=1 does not have to work there.
You can try to open Makefile and set MODULE_POWER manually to 1 in the file.

I try the compilation on Windows later today and I’ll let you know.


#5

Hello kutilak,

I’ve tested all on Windows and get the LED turn on.

  1. The compilation make release MODULE_POWER=1 works ok on Windows and creates working binary.
    Flash it with bcf flash.

  2. In Playground start pairing and disconnect, wait few seconds and reconnect power to the Core Module you just flashed. Stop pairing

  3. In Playground Devices you see paired module. Make sure the name is “generic-node:0” because you have to use same name in the MQTT topic later.

  4. In MQTT messages you see that the module has mode:0 which means the module radio never sleeps. Sleeping nodes have mode:3.

5.Create a simple flow with dasboard swich node, that returns true/false. And connect it with the MQTT node.

6.In Dasboard toggle the switch and Core Module LED will turn on and off

If you still have trouble to get this working, then send me console outputs, screenshots or a video what have you done and we’ll find a solution.

Martin


#6

after I change

override MODULE_POWER ?= 0

to

override MODULE_POWER ?= 1

and type in console

make release MODULE_POWER=1

it works :slight_smile:

I still learning how “C” works and how correct use it and how to use foreign code and libraries.

BigClown Playground dont work for me. I dont know if it able to connect with older core module but
everything I needed I did.

Thanks for support :slight_smile:


#7

Perfect that you have it working.
Let me know if you get stuck somewhere.
Martin


closed #8