Windows 10 compilation issue with sh.exe


#1

Hello together,

Core module + BigClown Toolchain + Visual Code Studio on Windows 7 is workign fine.
On new computer with Windos 10 I have a trouble.

My steps:

  • create new folder with “bcf create new” and open this folder in VSCode
  • In VSCode with “Ctrl+Shift+B” using “build” with error

Some issue in “sh.exe”???


USB Connection to Core module on Windows 10 64 bit
USB Connection to Core module on Windows 10 64 bit
#2

And second picture (new users can upload only one picture :frowning: )


#3

Hello, right click on your project’s folder, select BigClown Toolchain and try to run make directly from the command line. Does it work?


#4

For DFU troubleshooting use https://bigclown.netlify.com/doc/firmware/toolchain-guide/#troubleshoot-windows-dfu-flash please.


#5

@hub.martin - I will try it, thx
@michal.muhlpachr - I made this before ( “Core module isn’t recognize but with Zadig is OK”)


#6

@waldi.cz v1.0.2 of toolchain has better DFU driver installation, it should fix DFU driver installation (for PCs, where wrong driver is not active). For DFU driver troubleshooting from terminal, there is https://bigclown.netlify.com/doc/firmware/toolchain-guide/#troubleshoot-windows-dfu-flash


#7

Kind of but different shell :wink: Thank you for report.

VSCode default shell is now Powershell (instead of cmd for Ctrl-`) and powershell execution environment does not taste well for make (I am not sure why, I will check it later).

With “terminal.integrated.shell.windows”: “C:\Windows\sysnative\cmd.exe” VSCode configuration build executes fine.
Would you be so kind and test it with your configuration please ?

We need update VSCode integration anyway, so I will fix it together.


#8

Yes, it’s working well.


#9

Hello Michal,

I tryed add to file settings.json in project this:
“terminal.integrated.shell.windows”: “C:\Windows\SysWOW64\cmd.exe”
(the path C:\Windows\SysWOW64\cmd.exe is working)

But without change when try to build.


#10

Did you tried to close the project and load it again?
Maybe the Visual Studio loads settings.json only when the project is opened.


#11

@hub.martin Yes, I tried close VSCode, I tried restart computer, I tried BigClown Toolchain 1.0.2 and reinstall VSCode, but no effect. Is necessary to buit it int command line with “make”.


#12

Your VSCode Workspace is PRVNI (not PRVNI\sdk), you have to put terminal configuration in Workspace top .vscode\settings.json file. Would you be so kind and try to create settings.json in Workspace top level .vscode and put terminal configuration there please (no need to restart or reinstall) ?

Or you can use user settings Ctrl-,

Does it work for you please ?


#13

@michal.muhlpachr I had information from @hub.martin about add “terminal.integrated.shell.windows”: “C:\Windows\SysWOW64\cmd.exe” to file “settings.json” and only one file with this name was in folder \sdk.

Now I added this to setting in VSCode (with Ctrl-,) and it’s working well! Thank you for your support!
Next, you will change it in all projects?


#14

Right place for project related settings.json is in WORKSPACE/.vscode/settings.json, in your case PRVNI/.vscode/settings.json (not PRVNI/sdk/.vscode/settings.json).

Definetly, I will fix it in project skeleton. Thank you for testing in your configuration and reporting results.